Author Topic: Sound bug whenever I open MTA settings  (Read 432 times)

Offline OhhKarim

  • Junior Community Member
  • *
  • Underrated.
  • Registered: 16/05/2015
    YearsYearsYears
  • Group: eXodus - LynX
  • Ingame: Karim
  • Squad: NoAP4U
Sound bug whenever I open MTA settings
« on: 17 12, 2018, 12:45:54 am »
Every time I open my MTA settings my sound disappears and I have to re-open MTA to fix it. I already checked my sound system and my MTA is updated, it doesn't happen when I search for servers, specifically just the MTA settings. I really need to fix this asap.
* [Quick Stats] Total kills made: 93,000
Road to 100k.

Smashing 2012'ers since 2015.

(ADVERT) [CIT]Cerberus: Congratulations Karim for JCM! #OhhKarim #OhhJCM

Offline Nidus

  • Regular Community Member
  • **
  • I reject rejection
  • Registered: 12/02/2017
    Years
Re: Sound bug whenever I open MTA settings
« Reply #1 on: 17 12, 2018, 02:22:04 am »
I've found out the reason why it is bugged: you probably punch alot with your fist while in game, this can not be fixed except less punching, hope it works.
That's how much we have in common.
Currently a Business board moderator and proud.
#RIPDSCL

Offline Zelda

  • Regular Community Member
  • **
  • Lua/PHP/JS/HTML programmer.
  • Registered: 26/05/2014
    YearsYearsYearsYears
  • Group: HispanicGamers
  • Ingame: Zelda
Re: Sound bug whenever I open MTA settings
« Reply #2 on: 17 12, 2018, 01:14:40 pm »
Hello, I think you can try to verify the version of your sound driver, try download and install Driver Easy: https://www.drivereasy.com/DriverEasy_Setup.exe
Show content
Then click "Scan Now" button. Driver Easy will scan your computer and provide you with new drivers instantly.
My translator system script for MTA.
https://community.multitheftauto.com/?p=resources&s=details&id=15522

Proud Ex DS1 Moderator [GUIDE] /ds interface

If you need a script for your suggestion, you can mention me.

Offline Speedy

  • ***
  • The Expert
  • Registered: 18/07/2017
    Years
  • Group: WingsOfGold
  • Ingame: Left
Re: Sound bug whenever I open MTA settings
« Reply #3 on: 17 12, 2018, 07:25:33 pm »
try this mta version: https://nightly.mtasa.com/mtasa-1.5.6-rc-16074-20181205.exe
if it didnt work, download 'Driver Booster' and Update ur 'Sound Driver' (you can update all your Drivers too)
Check ur gta sound files too, if it is broken (doesnt work) verify it in gta not mta.

Offline RiDz

  • Regular Community Member
  • **
  • Inactive till March. Exams buddy.
  • Registered: 20/04/2015
    YearsYearsYears
  • Ingame: RiDz
  • Squad: Scooter Brother
Re: Sound bug whenever I open MTA settings
« Reply #4 on: 21 12, 2018, 05:52:11 am »
@OhhKarim Have you fixed it?
Nibbas like y'all is what I call wannabes
And ain't shit compared to real muthaphuckkin' G's

Offline OhhKarim

  • Junior Community Member
  • *
  • Underrated.
  • Registered: 16/05/2015
    YearsYearsYears
  • Group: eXodus - LynX
  • Ingame: Karim
  • Squad: NoAP4U
Re: Sound bug whenever I open MTA settings
« Reply #5 on: 21 12, 2018, 03:23:08 pm »
I've found out the reason why it is bugged: you probably punch alot with your fist while in game, this can not be fixed except less punching, hope it works.
Who told you this nonsense? My friends all punch a lot with fist and it doesn't happen to them, and even when I login right away without doing anything, and I go to the settings, it's still bugged.
Hello, I think you can try to verify the version of your sound driver, try download and install Driver Easy: https://www.drivereasy.com/DriverEasy_Setup.exe
Show content
Then click "Scan Now" button. Driver Easy will scan your computer and provide you with new drivers instantly.

It's up to date.
try this mta version: https://nightly.mtasa.com/mtasa-1.5.6-rc-16074-20181205.exe
I'm using the newest MTA version from Arran's topic and it's still happening.
if it didnt work, download 'Driver Booster' and Update ur 'Sound Driver' (you can update all your Drivers too)
It's updated.
Check ur gta sound files too, if it is broken (doesnt work) verify it in gta not mta.
I re-installed GTA and uninstalled all mods and it still happens.
@OhhKarim Have you fixed it?
Unfortunately not, but thanks for all the help so far. This all happened out-of-the-blue since a couple months now.
* [Quick Stats] Total kills made: 93,000
Road to 100k.

Smashing 2012'ers since 2015.

(ADVERT) [CIT]Cerberus: Congratulations Karim for JCM! #OhhKarim #OhhJCM

Offline Nidus

  • Regular Community Member
  • **
  • I reject rejection
  • Registered: 12/02/2017
    Years
Re: Sound bug whenever I open MTA settings
« Reply #6 on: 21 12, 2018, 03:33:18 pm »
Who told you this nonsense? My friends all punch a lot with fist and it doesn't happen to them, and even when I login right away without doing anything, and I go to the settings, it's still bugged.
Nobody told me such thing but that is what I got when punching with fist alot in the game honestly, or might be due to the excessive number of explosives so it bugs out the sound, anyways.
That's how much we have in common.
Currently a Business board moderator and proud.
#RIPDSCL

Offline OhhKarim

  • Junior Community Member
  • *
  • Underrated.
  • Registered: 16/05/2015
    YearsYearsYears
  • Group: eXodus - LynX
  • Ingame: Karim
  • Squad: NoAP4U
Re: Sound bug whenever I open MTA settings
« Reply #7 on: 26 12, 2018, 02:52:50 pm »
Nobody told me such thing but that is what I got when punching with fist alot in the game honestly, or might be due to the excessive number of explosives so it bugs out the sound, anyways.
Well like I said, it already happens once I log into the game before any explosives or fist punching occurs. Anyone else got any other possible suggestions?
* [Quick Stats] Total kills made: 93,000
Road to 100k.

Smashing 2012'ers since 2015.

(ADVERT) [CIT]Cerberus: Congratulations Karim for JCM! #OhhKarim #OhhJCM

Offline Roster46

  • ***
  • Helper
  • Registered: 09/03/2018
  • Group: Pirus
  • Ingame: Roster46
Re: Sound bug whenever I open MTA settings
« Reply #8 on: 26 12, 2018, 06:03:46 pm »
Well like I said, it already happens once I log into the game before any explosives or fist punching occurs. Anyone else got any other possible suggestions?
When you log the game then it's happen ?

Offline Zelda

  • Regular Community Member
  • **
  • Lua/PHP/JS/HTML programmer.
  • Registered: 26/05/2014
    YearsYearsYearsYears
  • Group: HispanicGamers
  • Ingame: Zelda
Re: Sound bug whenever I open MTA settings
« Reply #9 on: 01 01, 2019, 09:52:00 pm »
Possibly the crash occured while playing a GTA sound effect. Your audio files are either corrupted or do not exist at all, Karim run MTADiag and paste the log in this topic: https://nightly.mtasa.com/files/MTADiag.exe.
My translator system script for MTA.
https://community.multitheftauto.com/?p=resources&s=details&id=15522

Proud Ex DS1 Moderator [GUIDE] /ds interface

If you need a script for your suggestion, you can mention me.

Offline sheRRy

  • ***
  • "Nothing scares me but God"
  • Registered: 21/01/2017
    Years
  • Group: Scary_Killers
  • Ingame: sheRRy
  • Squad: Falken
Re: Sound bug whenever I open MTA settings
« Reply #10 on: 03 01, 2019, 04:20:14 pm »
Try reinstalling Windows or Sound drivers.

Offline OhhKarim

  • Junior Community Member
  • *
  • Underrated.
  • Registered: 16/05/2015
    YearsYearsYears
  • Group: eXodus - LynX
  • Ingame: Karim
  • Squad: NoAP4U
Re: Sound bug whenever I open MTA settings
« Reply #11 on: 03 01, 2019, 04:22:37 pm »
Possibly the crash occured while playing a GTA sound effect. Your audio files are either corrupted or do not exist at all, Karim run MTADiag and paste the log in this topic: https://nightly.mtasa.com/files/MTADiag.exe.
https://pastebin.mtasa.com/150473668

Ran it once I opened settings to make sure the audio was off by the bug.

Edit: Now when I play, there's no sound at all without even going to the settings.
https://pastebin.mtasa.com/174911383
« Last Edit: 03 01, 2019, 06:57:04 pm by OhhKarim »
* [Quick Stats] Total kills made: 93,000
Road to 100k.

Smashing 2012'ers since 2015.

(ADVERT) [CIT]Cerberus: Congratulations Karim for JCM! #OhhKarim #OhhJCM

Offline Zelda

  • Regular Community Member
  • **
  • Lua/PHP/JS/HTML programmer.
  • Registered: 26/05/2014
    YearsYearsYearsYears
  • Group: HispanicGamers
  • Ingame: Zelda
Re: Sound bug whenever I open MTA settings
« Reply #12 on: 04 01, 2019, 08:27:44 am »
Some files from GTA were modified by some cause recently. here I found some problems in your logs:

Quote
MD5sum for \audio\CONFIG\BankLkup.dat: cd8d23472903b6ed0723ec3f05883745   Size: 8520
Value should be:  b45905c794677467644240aa9abc2f60

MD5sum for \audio\SFX\GENRL: a980f05142b75258cc321fbf5833e339   Size: 25296604
Value should be:  7813ccc099987ff9e51c136ed919f665
 
MD5sum for \data\timecyc.dat: 956e10eb3b910de4a5062532d32261a8   Size: 38453
Value should be:  d66a121bc8f17a5b69e34b841744956c
 
MD5sum for \models\effects.fxp: 3c0153ac38a6d6cbf265518136aa9520   Size: 2483679
Value should be:  6143a72e8ff2974db14f65df65d952b0

MD5sum for \models\effectsPC.txd: 9873d53f0d9967e099720183c87f3bde   Size: 16034984
Value should be:  0802650dfea37ed516e1c0f12ccb77d7

MD5sum for \models\fonts.txd: c8da6b7011ebb26aa787b5b25632f999   Size: 6641316
Value should be:  3ea286fb7d7086d353b42a8e2b021cea

MD5sum for \models\hud.txd: 39ec68e608a36df503112b21e5a13cad   Size: 113064
Value should be:  18d2abd58e28c06b721197a0458d4405
 
MD5sum for \models\particle.txd: 2323c273c75e65df3c338baee4c41c09   Size: 650536
Value should be:  585f47abb0a6ea6c17d5a7638a1a07d9

I have uploaded all files in a folder:
Do not post links to copyrighted material.

Then install these files in the following order:
C:\Program Files\Rockstar Games\GTA San Andreas\audio\CONFIG\BankLkup.dat
C:\Program Files\Rockstar Games\GTA San Andreas\audio\SFX\GENRL
C:\Program Files\Rockstar Games\GTA San Andreas\data\timecyc.dat
C:\Program Files\Rockstar Games\GTA San Andreas\models\effects.fxp
C:\Program Files\Rockstar Games\GTA San Andreas\models\effectsPC.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\effectsPC.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\fonts.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\hud.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\particle.txd
« Last Edit: 11 01, 2019, 06:24:12 pm by Arran »
My translator system script for MTA.
https://community.multitheftauto.com/?p=resources&s=details&id=15522

Proud Ex DS1 Moderator [GUIDE] /ds interface

If you need a script for your suggestion, you can mention me.

Offline OhhKarim

  • Junior Community Member
  • *
  • Underrated.
  • Registered: 16/05/2015
    YearsYearsYears
  • Group: eXodus - LynX
  • Ingame: Karim
  • Squad: NoAP4U
Re: Sound bug whenever I open MTA settings
« Reply #13 on: 04 01, 2019, 02:25:16 pm »
Some files from GTA were modified by some cause recently. here I found some problems in your logs:

I have uploaded all files in a folder:
Do not post links to copyrighted material.

Then install these files in the following order:
C:\Program Files\Rockstar Games\GTA San Andreas\audio\CONFIG\BankLkup.dat
C:\Program Files\Rockstar Games\GTA San Andreas\audio\SFX\GENRL
C:\Program Files\Rockstar Games\GTA San Andreas\data\timecyc.dat
C:\Program Files\Rockstar Games\GTA San Andreas\models\effects.fxp
C:\Program Files\Rockstar Games\GTA San Andreas\models\effectsPC.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\effectsPC.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\fonts.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\hud.txd
C:\Program Files\Rockstar Games\GTA San Andreas\models\particle.txd
Hi, I installed them except hud/particle/effects/GENRL because I installed some mods. Like custom M4 sound, custom fist, custom effects. And it's still bugged, or do I really have to remove everything? Or can I add them back after it?
« Last Edit: 11 01, 2019, 06:24:19 pm by Arran »
* [Quick Stats] Total kills made: 93,000
Road to 100k.

Smashing 2012'ers since 2015.

(ADVERT) [CIT]Cerberus: Congratulations Karim for JCM! #OhhKarim #OhhJCM

Offline Zelda

  • Regular Community Member
  • **
  • Lua/PHP/JS/HTML programmer.
  • Registered: 26/05/2014
    YearsYearsYearsYears
  • Group: HispanicGamers
  • Ingame: Zelda
Re: Sound bug whenever I open MTA settings
« Reply #14 on: 04 01, 2019, 06:38:30 pm »
Hi, I installed them except hud/particle/effects/GENRL because I installed some mods. Like custom M4 sound, custom fist, custom effects. And it's still bugged, or do I really have to remove everything? Or can I add them back after it?

Make a backup of those files that you modified, and try to do what I told you to see if your problem is solved.
My translator system script for MTA.
https://community.multitheftauto.com/?p=resources&s=details&id=15522

Proud Ex DS1 Moderator [GUIDE] /ds interface

If you need a script for your suggestion, you can mention me.